modified on 20 lip 2010 at 12:35 ••• 33 640 views

Interfejs/EoIP

Z MikroTik Wiki

(Przekierowano z EoIP)

Spis treści

Opis Ogólny

Wprowadzenie

Tunelowanie Ethernet over IP (EoIP) jest protokołem MikroTik RouterOS, który tworzy tunel Ethernet pomiędzy dwoma routerami nad połączeniem IP. Interfejs EoIP traktowany jest jak interfejs Ethernet. Gdy na routerze funkcja połączenia mostkowego jest włączona, cały ruch Ethernetowy (wszystkie protokoły Ethernetowe) będzie przenoszony przez EoIP tak, jakby istniał fizyczny interfejs Ethernetowy i kabel pomiędzy dwoma routerami (z włączoną funkcją połączenia mostkowego). Ten protokół umożliwia powstawanie wielu układów sieci.

Sieć może się składać z poniższych interfejsów EoIP:

  • Możliwość przenoszenia LAN-u przez Internet
  • Możliwość przenoszenia LAN-u przez tunele szyfrowane
  • Możliwość przenoszenia LAN-u przez sieci bezprzewodowe 802.11b typu 'ad-hoc'

Szybka Konfiguracja

Aby stworzyć tunel EoIP pomiędzy dwoma routerami o adresach IP 10.5.8.1 i 10.1.0.1:

1. Na routerze o adresie 10.5.8.1, dodaj interfejs EoIP i ustaw jego adres MAC:

/interface eoip add remote-address=10.1.0.1 tunnel-id=1 mac-address=00-00-5E-80-00-01 \
\... disabled=no

2. Na routerze o adresie 10.1.0.1, dodaj interfejs EoIP i ustaw jego adres MAC:

/interface eoip add remote-address=10.5.8.1 tunnel-id=1 mac-address=00-00-5E-80-00-02 \
\... disabled=no

Teraz możesz nadać adres IP stworzonemu interfejsowi EoIP tej samej podsieci.

Specyfikacja

Wymagane pakiety: system

Wymagana licencja: Level1 (ograniczony do 1 tunelu), Level3 '

Poziom menu: /interface eoip

Standardy i technologie: GRE (RFC1701)

Wykorzystanie sprzętu: -

Opis

Interfejs EoIP może być zestawiony pomiędzy dwoma routerami posiadającymi aktywne połączenie poziomu IP. Tunel EoIP może działać na tunelu IPIP, szyfrowanym 128bitowym tunelu PPTP, połączeniu PPPoE, lub innym dowolnym połączeniu przenoszącym IP.

Specyficzne ustawienia:

  • Każdy interfejs tunelu EoIP może się łączyć ze zdalnym routerem, który posiada odpowiedni interfejs z tym samym parametrem 'Tunnel IP'.
  • Interfejs EoIP traktowany jest jak interfejs Ethernetowy na liście interfejsów.
  • Interfejs EoIP obsługuję wszystkie usługi interfejsu Ethernetowego. Adres IP oraz inne tunele mogą być tworzone na tym interfejsie.
  • Protokół EoIP enkapsuluje ramki Ethernetowe w pakietach GRE(protokół IP numer 47) (tak jak PPTP) i wysyła je na drugą stronę tunelu EoIP.
  • Maksymalna ilość tuneli EoIP wynosi 65536.

Uwagi

WDS jest znacząco szybszy niż EoIP na łączach bezprzewodowych ( 10-20% systemów RouterBOARD 500), więc zalecane jest używać WDS jeżeli jest to możliwe.

Konfiguracja EoIP

Poziom menu: /interface eoip

Opis własności

arp (disabled | enabled | proxy-arp | reply-only; default: enabled) - Address Resolution Protocol

mac-address (MAC address) - Adres MAC interfejsu EoIP. Dozwolone jest używanie adresu MAC w zakresie od 00:00:5E:80:00:00 do 00:00:5E:FF:FF:FF.Inne adresy też mogą być używane, ale nie jest to polecane. Powinieneś zapewnić unikalność adresu MAC wewnątrz sieci EoIP.

mtu (integer; default: 1500) - Maksymalny rozmiar pakietu (Maximum Transmission Unit). Domyślna wartość zapewnia maksymalną kompatybilność, jednak może doprowadzić do zmniejszenia wydajność w łączach bezprzewodowych z powodu fragmentacji. Jeżeli zwiększysz MTU na wszystkich łączach możesz odzyskać optymalną wydajność.

name (name; default: eoip-tunnelN) - Nazwa interfejsu

remote-address - adres IP po drugiej stronie tunelu EoIP - musi być routerem MikroTik

tunnel-id (integer) - unikalny identyfikator tunelu, musi być taki sam po obu stronach tunelu

Uwagi

Tunnel-id jest metodą identyfikacji tunelu. Nie powinno być tuneli z tym samym Tunnel-id na tym samym routerze.Tunnel-id dla obu połączonych routerach musi być takie same.

MTU powinno mieć wartość równą 1500 aby wyeleminować fragmentację pakietów wewnątrz tunelu (pozwala na to przezroczyste łącze mostkowe sieci ethernetopodobnych, więc będzie możliwe przenoszenie całej ramki Ethernetowej normalnego rozmiaru przez tunel).

Gdy łączymy mostkowo tunele EoIP, zalecane jest ustawić unikalne adresy MAC dla każdego tunelu, aby algorytmy połączeń mostkowych działały poprawnie. Dla interfejsów EoIP możesz użyć adresów MAC mieszczących się w zakresie od 00:00:5E:80:00:00 do 00:00:5E:FF:FF:FF, które IANA zarezerwowało dla takich przypadków. Ewentualnie możesz ustawić drugi bit pierwszego bajtu aby zaznaczyć, że adres jest adresem zarządzanym lokalnie, przydzielonym przez administratora sieci. Wtedy możesz użyć dowolnego adresu MAC. Tylko musisz się upewnić, że adresy MAC wśród hostów połączonych z mostkiem nie powtarzają się.

Przykład

Aby stworzyć i włączyć tunel EoIP o nazwie to_mt2 na routerze 10.5.8.1, wpisz wartość tunnel-id równą 1:

[admin@MikroTik] interface eoip> add name=to_mt2 remote-address=10.5.8.1 \
\... tunnel-id 1
[admin@MikroTik] interface eoip> print
Flags: X - disabled, R - running
  0 X  name="to_mt2" mtu=1500 arp=enabled remote-address=10.5.8.1 tunnel-id=1

[admin@MikroTik] interface eoip> enable 0
[admin@MikroTik] interface eoip> print
Flags: X - disabled, R - running
  0 R  name="to_mt2" mtu=1500 arp=enabled remote-address=10.5.8.1 tunnel-id=1

[admin@MikroTik] interface eoip>

Przykład aplikacji EoIP

Opis

Załóżmy, że chcemy połączyć mostkowo dwie sieci: 'Office LAN' i 'Remote LAN'. Sieci są podłączone do sieci IP przez routery [Our_GW] oraz [Remote]. Sieć IP może być prywatnym intranetem lub Internetem. Obydwa routery mogą komunikować się między sobą przez sieć IP.

Przykład

Naszym celem jest stworzenie bezpiecznego kanału pomiędzy routerami i połączyć mostkowo przez niego obie sieci. Schemat układu sieci wygląda następująco:

Grafika:eoip_net.jpg

Aby stworzyć bezpieczne Ethernetowe połączenie mostkowe pomiędzy routerami należy:

1. Stworzyć tunel PPTP pomiędzy nimi. Our_GW będzie serwerem PPTP:

[admin@Our_GW] interface pptp-server> /ppp secret add name=joe service=pptp \
\... password=top_s3 local-address=10.0.0.1 remote-address=10.0.0.2
[admin@Our_GW] interface pptp-server> add name=from_remote user=joe
[admin@Our_GW] interface pptp-server> server set enable=yes
[admin@Our_GW] interface pptp-server> print
Flags: X - disabled, D - dynamic, R - running
 #     NAME         USER         MTU        CLIENT-AD... UPTIME   ENCODING
 0     from_remote  joe
[admin@Our_GW] interface pptp-server>

The Remote router will be the pptp client: 

[admin@Remote] interface pptp-client> add name=pptp user=joe \
\... connect-to=192.168.1.1 password=top_s3 mtu=1500 mru=1500
[admin@Remote] interface pptp-client> enable pptp
[admin@Remote] interface pptp-client> print
Flags: X - disabled, R - running
  0  R name="pptp" mtu=1500 mru=1500 connect-to=192.168.1.1 user="joe"
       password="top_s2" profile=default add-default-route=no

[admin@Remote] interface pptp-client> monitor pptp
      status: "connected"
      uptime: 39m46s
    encoding: "none"

[admin@Remote] interface pptp-client>

Przeczytaj podręcznik interfejsu PPTP aby dowiedzieć się więcej o zestawianiu kanałów szyfrowanych.

2. Skonfiguruj tunel EoIP przez dodanie interfejsów tunelu EoIP w obu routerach. Przy określaniu wartości parametrów tunelu EoIP użyj adresów IP interfejsów tunelu PPTP.

[admin@Our_GW] interface eoip> add name="eoip-remote" tunnel-id=0 \
\... remote-address=10.0.0.2
[admin@Our_GW] interface eoip> enable eoip-remote
[admin@Our_GW] interface eoip> print
Flags: X - disabled, R - running
  0    name=eoip-remote mtu=1500 arp=enabled remote-address=10.0.0.2 tunnel-id=0
[admin@Our_GW] interface eoip>

[admin@Remote] interface eoip> add name="eoip" tunnel-id=0 \
\... remote-address=10.0.0.1
[admin@Remote] interface eoip> enable eoip-main
[admin@Remote] interface eoip> print
Flags: X - disabled, R - running
  0   name=eoip mtu=1500 arp=enabled remote-address=10.0.0.1 tunnel-id=0

[Remote] interface eoip>

3. Stwórz połączenie mostkowe pomiędzy interfejsami EoIP i Ethernet w obu routerach.

Dla 'Our_GW':

[admin@Our_GW] interface bridge> add 
[admin@Our_GW] interface bridge> print
Flags: X - disabled, R - running
 0  R name="bridge1" mtu=1500 arp=enabled mac-address=00:00:00:00:00:00 
      protocol-mode=none priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s 
      transmit-hold-count=6 ageing-time=5m 
[admin@Our_GW] interface bridge> port add bridge=bridge1 interface=eoip-remote
[admin@Our_GW] interface bridge> port add bridge=bridge1 interface=office-eth
[admin@Our_GW] interface bridge> port print
Flags: X - disabled, I - inactive, D - dynamic
 #    INTERFACE      BRIDGE  PRIORITY PATH-COST
 0    eoip-remote    bridge1 128      10
 1    office-eth     bridge1 128      10
[admin@Our_GW] interface bridge>

To samo dla 'Remote':

[admin@Remote] interface bridge> add 
[admin@Remote] interface bridge> print
Flags: X - disabled, R - running
 0  R name="bridge1" mtu=1500 arp=enabled mac-address=00:00:00:00:00:00 
      protocol-mode=none priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s 
      transmit-hold-count=6 ageing-time=5m 
[admin@Remote] interface bridge> port add bridge=bridge1 interface=ether
[admin@Remote] interface bridge> port add bridge=bridge1 interface=eoip-main
[admin@Remote] interface bridge> port print
Flags: X - disabled, I - inactive, D - dynamic
 #    INTERFACE      BRIDGE  PRIORITY PATH-COST
 0    ether          bridge1 128      10
 1    eoip-main      bridge1 128      10     
[admin@Remote] interface bridge>

4. Adresy tej samej sieci mogą być używane w 'Office LAN' jak i 'Remote LAN'.

Rozwiązywanie Problemów

Opis

  • Routery mogą pingować siebie nawzajem, ale tunel EoIP nie działa!

Sprawdź adresy MAC interfejsów EoIP - nie mogą być takie same!